Reply
Nov 07 2010
By: gameking1Duke First Son 3 posts
Offline

Glitch I am experiencing both on demo + full game

9 replies 571 views Edited Nov 7, 2010

In the beginning of the game, after you beat the minotaur/bull monster, there is a ledge lit up near by. When you jump up to hold on to the ledge, a hint comes up saying "hold analog stick toward the next ledge. Press x to vault across the gap." However, the game does not allow me to do this. Every time I've done this both in the demo and the full game, I have not been able to get Kratos to vault across the gap and I can't get any farther than that part in the game because of it.

Has anyone else experienced this or know how to fix it? And is there a patch out there for this glitch because I really need it. By the way, I'm playing on the classic PSP-1001 but I don't think that really influences the glitch.

Message 1 of 10 (571 Views)
Reply
0 Likes
Hekseville Citizen
Registered: 03/08/2009
Offline
367 posts
 

Re: Glitch I am experiencing both on demo + full game

Nov 7, 2010

did you pirate the game? because i saw that in other forums and they said only people who pirate it experience that

PERFECTIONIST
Message 2 of 10 (571 Views)
Reply
0 Likes
First Son
Registered: 03/28/2007
Offline
3 posts
 

Re: Glitch I am experiencing both on demo + full game

Nov 7, 2010

no neither of these versions of the game were pirated. the demo was downloaded from PSN and the games was bought from best buy. yet I am still experiencing this issue.

Message 3 of 10 (571 Views)
Reply
0 Likes
I Only Post Everything
Registered: 12/18/2009
Offline
1279 posts
 

Re: Glitch I am experiencing both on demo + full game

Nov 8, 2010

No clue man, I have never heard of that problem, you sure you're not doing something wrong? I have played the demo on both a psp 1000 and 3000 and it worked fine.

"If all on Olympus will deny me my vengeance, then all on Olympus will die"- Kratos, GOW2
Message 4 of 10 (571 Views)
Reply
0 Likes
First Son
Registered: 10/06/2010
Offline
2 posts
 

Re: Glitch I am experiencing both on demo + full game

Nov 9, 2010

I was having a similar glitch going on where I couldn't use a crane side as a ladder no matter what I tried. I wasted half an hour and gave up for the night and came back to it the next day. Sure enough, I tried it again, and it still wouldn't let me go up the crane like a ladder even though it was clearly the only way to get up atop the second floor of the crane where there is a switch/lever you need to pull. Finally, thank the gods, it just let me shoot straight up "the ladder" and carry on as if it wasn't giving me troubles earlier on. Can't explain it. AWESOME game though, just finished it tonight. Loved the story, loved the unique fighting, weapons, and sheer violence God of War always seems to radiate. Fun stuff.

Message 5 of 10 (571 Views)
Reply
0 Likes
First Son
Registered: 03/15/2009
Offline
1 posts
 

Re: Glitch I am experiencing both on demo + full game

Dec 25, 2010

i have the same exact problem have u gotten it yet

Message 6 of 10 (571 Views)
Reply
0 Likes
I Only Post Everything
Registered: 12/25/2008
Offline
1336 posts
 

Re: Glitch I am experiencing both on demo + full game

Dec 25, 2010

try pointing the analog stick slightly towards right.

Message 7 of 10 (571 Views)
Reply
0 Likes
First Son
Registered: 02/05/2009
Offline
18 posts
 

Re: Glitch I am experiencing both on demo + full game

Dec 15, 2011

I know this thread is old, but does any one could pass that part and how? i'm playing the complete game for the first time and i'm stuck at the same place. It says to hold stick toward and press X, but it would not jump to grab the high ledge. The game is not pirated, so that's not the problem.

Message 8 of 10 (571 Views)
Reply
0 Likes
Treasure Hunter
Registered: 01/15/2006
Offline
5821 posts
 

Re: Glitch I am experiencing both on demo + full game

Jan 26, 2012

I believe he notes passing it in another thread.

Message 9 of 10 (571 Views)
Reply
0 Likes
Highlighted
First Son
Registered: 02/05/2009
Offline
18 posts
 

Re: Glitch I am experiencing both on demo + full game

Jan 26, 2012

It has something to do with the battery, strangely. I took the battery out and played directly to A\C and worked. After that, no more problem even if i replay the game again.

Message 10 of 10 (571 Views)
Reply
0 Likes